What’s Vulnerable › Vulnerabilities
CVE-2019-11282: UAA is vulnerable to a Blind SCIM injection leading to information disclosure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-23 · updated 2026-06-17
- Weakness: CWE-200
Description
Cloud Foundry UAA, versions prior to v74.3.0, contains an endpoint that is vulnerable to SCIM injection attack. A remote authenticated malicious user with scim.invite scope can craft a request with malicious content which can leak information about users of the UAA.
Affected products
- Cloud Foundry cf-deployment: before 12.2.0 — fixed in 12.2.0
- Cloud Foundry UAA: before 74.3.0 — fixed in 74.3.0
How to fix
Upgrade to a fixed version: Cloud Foundry cf-deployment 12.2.0; Cloud Foundry UAA 74.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-11282 or the next vulnerability affects your stack