What’s Vulnerable › Vulnerabilities

CVE-2019-11286: JMX Credential Deserialization in GemFire

Description

VMware GemFire versions prior to 9.10.0, 9.9.1, 9.8.5, and 9.7.5, and VMware Tanzu GemFire for VMs versions prior to 1.11.0, 1.10.1, 1.9.2, and 1.8.2, contain a JMX service available to the network which does not properly restrict input. A remote authenticated malicious user may request against the service with a crafted set of credentials leading to remote code execution.

Affected products

How to fix

Upgrade to a fixed version: VMware Gemfire 9.7.5, 9.8.5, 9.9.1; VMware Tanzu Gemfire For Virtual Machines 1.10.1, 1.8.2, 1.9.2; VMware Gemfire 9.7.5, 9.8.5, 9.9.1, 9.10.0; VMware Tanzu GemFire for VMs 1.9.2, 1.10.1, 1.8.2, 1.11.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-11286 or the next vulnerability affects your stack