What’s Vulnerable › Vulnerabilities

CVE-2019-11287: RabbitMQ Web Management Plugin DoS via heap overflow

Description

Pivotal RabbitMQ, versions 3.7.x prior to 3.7.21 and 3.8.x prior to 3.8.1, and RabbitMQ for Pivotal Platform, 1.16.x versions prior to 1.16.7 and 1.17.x versions prior to 1.17.4, contain a web management plugin that is vulnerable to a denial of service attack. The "X-Reason" HTTP Header can be leveraged to insert a malicious Erlang format string that will expand and consume the heap, resulting in the server crashing.

Affected products

How to fix

Upgrade to a fixed version: rabbitmq-server 3.8.1; Pivotal RabbitMQ 1.16.7, 1.17.4, 3.7.21. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-11287 or the next vulnerability affects your stack