What’s Vulnerable › Vulnerabilities
CVE-2019-11289: A forged route service request using an invalid nonce can cause the gorouter to panic and crash
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-19 · updated 2026-06-17
- Weakness: CWE-20
Description
Cloud Foundry Routing, all versions before 0.193.0, does not properly validate nonce input. A remote unauthenticated malicious user could forge an HTTP route service request using an invalid nonce that will cause the Gorouter to crash.
Affected products
- Cloud Foundry cf-deployment: before 12.8.0 — fixed in 12.8.0
- Cloudfoundry Routing-Release: before 0.193.0 — fixed in 0.193.0
How to fix
Upgrade to a fixed version: Cloud Foundry cf-deployment 12.8.0; Cloudfoundry Routing-Release 0.193.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-11289 or the next vulnerability affects your stack