What’s Vulnerable › Vulnerabilities

CVE-2019-11291: RabbitMQ XSS attack via federation and shovel endpoints

Description

Pivotal RabbitMQ, 3.7 versions prior to v3.7.20 and 3.8 version prior to v3.8.1, and RabbitMQ for PCF, 1.16.x versions prior to 1.16.7 and 1.17.x versions prior to 1.17.4, contain two endpoints, federation and shovel, which do not properly sanitize user input. A remote authenticated malicious user with administrative access could craft a cross site scripting attack via the vhost or node name fields that could grant access to virtual hosts and policy management information.

Affected products

How to fix

Upgrade to a fixed version: rabbitmq-server 3.7.20; VMware Tanzu RabbitMQ 1.16.7, 1.17.4; Pivotal RabbitMQ v3.8.1, v3.7.20; Pivotal RabbitMQ for Pivotal Platform 1.17.4, 1.16.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-11291 or the next vulnerability affects your stack