What’s Vulnerable › Vulnerabilities
CVE-2019-11324
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-18 · updated 2026-06-17
- Weakness: CWE-295
Description
The urllib3 library before 1.24.2 for Python mishandles certain cases where the desired set of CA certificates is different from the OS store of CA certificates, which results in SSL connections succeeding in situations where a verification failure is the correct outcome. This is related to use of the ssl_context, ca_certs, or ca_certs_dir argument.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 18.10, 19.04
- urllib3: before 1.24.2 — fixed in 1.24.2
How to fix
Upgrade to a fixed version: urllib3 1.24.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00039.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00041.html
- http://www.openwall.com/lists/oss-security/2019/04/19/1
- https://access.redhat.com/errata/RHSA-2019:3335
- https://access.redhat.com/errata/RHSA-2019:3590
- https://github.com/urllib3/urllib3/compare/a6ec68a...1efadf4
- https://lists.debian.org/debian-lts-announce/2021/06/msg00015.html
- https://lists.debian.org/debian-lts-announce/2023/10/msg00012.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NKGPJLVLVYCL4L4B4G5TIOTVK4BKPG72/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XOSA2NT4DUQDBEIWE6O7KKD24XND7TE2/
- https://usn.ubuntu.com/3990-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00039.html
Get alerted when CVE-2019-11324 or the next vulnerability affects your stack