What’s Vulnerable › Vulnerabilities
CVE-2019-11339
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-19 · updated 2026-06-17
- Weakness: CWE-125
Description
The studio profile decoder in libavcodec/mpeg4videodec.c in FFmpeg 4.0 before 4.0.4 and 4.1 before 4.1.2 allows remote attackers to cause a denial of service (out-of-array access) or possibly have unspecified other impact via crafted MPEG-4 video data.
Affected products
- FFmpeg: from 4.0 before 4.0.4; from 4.1 before 4.1.2 — fixed in 4.0.4, 4.1.2
How to fix
Upgrade to a fixed version: FFmpeg 4.0.4, 4.1.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00012.html
- http://www.securityfocus.com/bid/108037
- https://github.com/FFmpeg/FFmpeg/commit/1f686d023b95219db933394a7704ad9aa5f01cbb
- https://github.com/FFmpeg/FFmpeg/commit/d227ed5d598340e719eff7156b1aa0a4469e9a6a
- https://usn.ubuntu.com/3967-1/
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00012.html
- http://www.securityfocus.com/bid/108037
- https://github.com/FFmpeg/FFmpeg/commit/1f686d023b95219db933394a7704ad9aa5f01cbb
- https://github.com/FFmpeg/FFmpeg/commit/d227ed5d598340e719eff7156b1aa0a4469e9a6a
- https://usn.ubuntu.com/3967-1/
Get alerted when CVE-2019-11339 or the next vulnerability affects your stack