What’s Vulnerable › Vulnerabilities

CVE-2019-11358: XSS in jQuery as used in Drupal, Backdrop CMS, and other products

Description

jQuery before 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles jQuery.extend(true, {}, ...) because of Object.prototype pollution. If an unsanitized source object contained an enumerable __proto__ property, it could extend the native Object.prototype.

Affected products

How to fix

Upgrade to a fixed version: backdropcms Backdrop 1.11.9, 1.12.6; Drupal 7.66, 8.5.15, 8.6.15; jQuery 3.4.0; Oracle Corporation Application Express 19.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-11358 or the next vulnerability affects your stack