What’s Vulnerable › Vulnerabilities
CVE-2019-11405
- Severity: high (CVSS 7.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-04-22 · updated 2026-06-17
- Weakness: CWE-311
Description
OpenAPI Tools OpenAPI Generator before 4.0.0-20190419.052012-560 uses http:// URLs in various build.gradle, build.gradle.mustache, and build.sbt files, which may have caused insecurely resolved dependencies.
Affected products
- OpenAPITools openapi-generator: before 4.0.0-20190419.052012-560 — fixed in 4.0.0-20190419.052012-560
How to fix
Upgrade to a fixed version: OpenAPITools openapi-generator 4.0.0-20190419.052012-560. Check the vendor advisory for mitigations.
References
- https://github.com/OpenAPITools/openapi-generator/issues/2253
- https://github.com/OpenAPITools/openapi-generator/pull/2248
- https://github.com/OpenAPITools/openapi-generator/pull/2697
- https://github.com/OpenAPITools/openapi-generator/issues/2253
- https://github.com/OpenAPITools/openapi-generator/pull/2248
- https://github.com/OpenAPITools/openapi-generator/pull/2697
Get alerted when CVE-2019-11405 or the next vulnerability affects your stack