What’s Vulnerable › Vulnerabilities
CVE-2019-11461
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-22 · updated 2026-06-17
Description
An issue was discovered in GNOME Nautilus 3.30 prior to 3.30.6 and 3.32 prior to 3.32.1. A compromised thumbnailer may escape the bubblewrap sandbox used to confine thumbnailers by using the TIOCSTI ioctl to push characters into the input buffer of the thumbnailer's controlling terminal, allowing an attacker to escape the sandbox if the thumbnailer has a controlling terminal. This is due to improper filtering of the TIOCSTI ioctl on 64-bit systems, similar to CVE-2019-10063.
Affected products
- GNOME Nautilus: from 3.30 before 3.30.6; from 3.32 before 3.32.1 — fixed in 3.30.6, 3.32.1
How to fix
Upgrade to a fixed version: GNOME Nautilus 3.30.6, 3.32.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00088.html
- https://gitlab.gnome.org/GNOME/nautilus/issues/987
- https://security.gentoo.org/glsa/201908-27
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00088.html
- https://gitlab.gnome.org/GNOME/nautilus/issues/987
- https://security.gentoo.org/glsa/201908-27
Get alerted when CVE-2019-11461 or the next vulnerability affects your stack