What’s Vulnerable › Vulnerabilities
CVE-2019-11517
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-06-10 · updated 2026-06-17
- Weakness: CWE-352
Description
WampServer before 3.1.9 has CSRF in add_vhost.php because the synchronizer pattern implemented as remediation of CVE-2018-8817 was incomplete. An attacker could add/delete any vhosts without the consent of the owner.
Affected products
- Wampserver: before 3.1.9 — fixed in 3.1.9
How to fix
Upgrade to a fixed version: Wampserver 3.1.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-11517 or the next vulnerability affects your stack