What’s Vulnerable › Vulnerabilities
CVE-2019-11552
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-19 · updated 2026-06-17
- Weakness: CWE-94
Description
Code42 Enterprise and Crashplan for Small Business Client version 6.7 before 6.7.5, 6.8 before 6.8.8, and 6.9 before 6.9.4 allows eval injection. A proxy auto-configuration file, crafted by a lesser privileged user, may be used to execute arbitrary code at a higher privilege as the service user.
Affected products
- Code42 For Enterprise: from 6.7 before 6.7.5; from 6.8 before 6.8.8; from 6.9 before 6.9.4 — fixed in 6.7.5, 6.8.8, 6.9.4
- Code42 Crashplan For Small Business: from 6.7 before 6.7.5; from 6.8 before 6.8.8; from 6.9 before 6.9.4 — fixed in 6.7.5, 6.8.8, 6.9.4
How to fix
Upgrade to a fixed version: Code42 For Enterprise 6.7.5, 6.8.8, 6.9.4; Code42 Crashplan For Small Business 6.7.5, 6.8.8, 6.9.4. Check the vendor advisory for mitigations.
References
- https://bordplate.no/blog/en/post/crashplan-privilege-escalation/
- https://code42.com/r/support/CVE-2019-11552
- https://bordplate.no/blog/en/post/crashplan-privilege-escalation/
- https://code42.com/r/support/CVE-2019-11552
Get alerted when CVE-2019-11552 or the next vulnerability affects your stack