What’s Vulnerable › Vulnerabilities
CVE-2019-11555
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-26 · updated 2026-06-17
- Weakness: CWE-476
Description
The EAP-pwd implementation in hostapd (EAP server) before 2.8 and wpa_supplicant (EAP peer) before 2.8 does not validate fragmentation reassembly state properly for a case where an unexpected fragment could be received. This could result in process termination due to a NULL pointer dereference (denial of service). This affects eap_server/eap_server_pwd.c and eap_peer/eap_pwd.c.
Affected products
- w1.fi hostapd: before 2.8 — fixed in 2.8
- Canonical Ltd. wpa_supplicant: before 2.8 — fixed in 2.8
How to fix
Upgrade to a fixed version: w1.fi hostapd 2.8; Canonical Ltd. wpa_supplicant 2.8. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2019/04/26/1
- https://lists.debian.org/debian-lts-announce/2019/07/msg00030.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/5T7G763UECWR7FQXOJVL67PW7C5A3SA4/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DJKZHAT5KPUN26JL77EUH563GAH5XZ5C/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IQ6P2GI5GSXRNLNIUNPARFZQVDEIGVZD/
- https://seclists.org/bugtraq/2019/May/40
- https://seclists.org/bugtraq/2019/May/64
- https://security.FreeBSD.org/advisories/FreeBSD-SA-19:03.wpa.asc
- https://security.gentoo.org/glsa/201908-25
- https://usn.ubuntu.com/3969-1/
- https://usn.ubuntu.com/3969-2/
- https://w1.fi/security/2019-5/
Get alerted when CVE-2019-11555 or the next vulnerability affects your stack