What’s Vulnerable › Vulnerabilities
CVE-2019-11565
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-04-27 · updated 2026-06-17
- Weakness: CWE-918
Description
Server Side Request Forgery (SSRF) exists in the Print My Blog plugin before 1.6.7 for WordPress via the site parameter.
Affected products
- Michael Nelson Print My Blog: before 1.6.7 — fixed in 1.6.7
How to fix
Upgrade to a fixed version: Michael Nelson Print My Blog 1.6.7. Check the vendor advisory for mitigations.
References
- http://dumpco.re/bugs/wp-plugin-print-my-blog-ssrf
- https://github.com/mnelson4/printmyblog/commit/8584a2839a541eb29fca64252e388c827af3ec21
- https://plugins.trac.wordpress.org/changeset?old_path=%2Fprint-my-blog%2Ftrunk&old=2075667&new_path=%2Fprint-my-blog%2Ftrunk&new=2075667
- https://wordpress.org/plugins/print-my-blog/#developers
- https://wpvulndb.com/vulnerabilities/9263
- http://dumpco.re/bugs/wp-plugin-print-my-blog-ssrf
- https://github.com/mnelson4/printmyblog/commit/8584a2839a541eb29fca64252e388c827af3ec21
- https://plugins.trac.wordpress.org/changeset?old_path=%2Fprint-my-blog%2Ftrunk&old=2075667&new_path=%2Fprint-my-blog%2Ftrunk&new=2075667
- https://wordpress.org/plugins/print-my-blog/#developers
- https://wpvulndb.com/vulnerabilities/9263
Get alerted when CVE-2019-11565 or the next vulnerability affects your stack