What’s Vulnerable › Vulnerabilities
CVE-2019-11576
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-28 · updated 2026-06-17
- Weakness: CWE-287
Description
Gitea before 1.8.0 allows 1FA for user accounts that have completed 2FA enrollment. If a user's credentials are known, then an attacker could send them to the API without requiring the 2FA one-time password.
Affected products
- Gitea Open Source Git Server: before 1.8.0 — fixed in 1.8.0
How to fix
Upgrade to a fixed version: Gitea Open Source Git Server 1.8.0. Check the vendor advisory for mitigations.
References
- https://blog.gitea.io/2019/04/gitea-1.8.0-is-released/
- https://github.com/go-gitea/gitea/pull/6674
- https://blog.gitea.io/2019/04/gitea-1.8.0-is-released/
- https://github.com/go-gitea/gitea/pull/6674
Get alerted when CVE-2019-11576 or the next vulnerability affects your stack