What’s Vulnerable › Vulnerabilities
CVE-2019-11604
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-05-24 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in Quest KACE Systems Management Appliance before 9.1. The script at /service/kbot_service_notsoap.php is vulnerable to unauthenticated reflected XSS when user-supplied input to the METHOD GET parameter is processed by the web application. Since the application does not properly validate and sanitize this parameter, it is possible to place arbitrary script code into the context of the same page.
Affected products
- Quest KACE: before 9.1 — fixed in 9.1
How to fix
Upgrade to a fixed version: Quest KACE 9.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/153053/Quest-KACE-Systems-Management-Appliance-9.0-Cross-Site-Scripting.html
- http://seclists.org/fulldisclosure/2019/May/40
- https://www.rcesecurity.com/
- http://packetstormsecurity.com/files/153053/Quest-KACE-Systems-Management-Appliance-9.0-Cross-Site-Scripting.html
- http://seclists.org/fulldisclosure/2019/May/40
- https://www.rcesecurity.com/
Get alerted when CVE-2019-11604 or the next vulnerability affects your stack