What’s Vulnerable › Vulnerabilities
CVE-2019-11605
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-09 · updated 2026-06-17
- Weakness: CWE-200
Description
An issue was discovered in GitLab Community and Enterprise Edition 11.8.x before 11.8.10, 11.9.x before 11.9.11, and 11.10.x before 11.10.3. It allows Information Disclosure. A small number of GitLab API endpoints would disclose project information when using a read_user scoped token.
Affected products
- GitLab: from 11.8.0 before 11.8.10; from 11.9.0 before 11.9.11; from 11.10.0 before 11.10.3 — fixed in 11.10.3, 11.8.10, 11.9.11
How to fix
Upgrade to a fixed version: GitLab 11.10.3, 11.8.10, 11.9.11. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/2019/04/30/security-release-gitlab-11-dot-10-dot-3-released/
- https://about.gitlab.com/2019/04/30/security-release-gitlab-11-dot-10-dot-3-released/
Get alerted when CVE-2019-11605 or the next vulnerability affects your stack