What’s Vulnerable › Vulnerabilities
CVE-2019-11627
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-04-30 · updated 2026-06-17
- Weakness: CWE-78
Description
gpg-key2ps in signing-party 1.1.x and 2.x before 2.10-1 contains an unsafe shell call enabling shell injection via a User ID.
Affected products
- Debian Linux: 8.0
- openSUSE Leap: 15.0, 42.3
- Signing-Party Project Signing-Party: from 1.1 before 2.10 — fixed in 2.10
How to fix
Upgrade to a fixed version: Signing-Party Project Signing-Party 2.10. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00029.html
- https://bugs.debian.org/928256
- https://lists.debian.org/debian-lts-announce/2019/05/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00029.html
- https://bugs.debian.org/928256
- https://lists.debian.org/debian-lts-announce/2019/05/msg00001.html
Get alerted when CVE-2019-11627 or the next vulnerability affects your stack