What’s Vulnerable › Vulnerabilities
CVE-2019-11693
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-23 · updated 2026-06-17
- Weakness: CWE-787
Description
The bufferdata function in WebGL is vulnerable to a buffer overflow with specific graphics drivers on Linux. This could result in malicious content freezing a tab or triggering a potentially exploitable crash. *Note: this issue only occurs on Linux. Other operating systems are unaffected.*. This vulnerability affects Thunderbird < 60.7, Firefox < 67, and Firefox ESR < 60.7.
Affected products
- Mozilla Firefox: before 60.7.0; before 67.0 — fixed in 60.7.0, 67.0
- Mozilla Thunderbird: before 60.7.0 — fixed in 60.7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 60.7.0, 67.0; Mozilla Thunderbird 60.7.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1532525
- https://www.mozilla.org/security/advisories/mfsa2019-13/
- https://www.mozilla.org/security/advisories/mfsa2019-14/
- https://www.mozilla.org/security/advisories/mfsa2019-15/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1532525
- https://www.mozilla.org/security/advisories/mfsa2019-13/
- https://www.mozilla.org/security/advisories/mfsa2019-14/
- https://www.mozilla.org/security/advisories/mfsa2019-15/
Get alerted when CVE-2019-11693 or the next vulnerability affects your stack