What’s Vulnerable › Vulnerabilities
CVE-2019-11707: Mozilla Firefox and Thunderbird Type Confusion Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-05-23
- EPSS: 37.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-23 · updated 2026-06-17
- Weakness: CWE-843
Description
A type confusion vulnerability can occur when manipulating JavaScript objects due to issues in Array.pop. This can allow for an exploitable crash. We are aware of targeted attacks in the wild abusing this flaw. This vulnerability affects Firefox ESR < 60.7.1, Firefox < 67.0.3, and Thunderbird < 60.7.2.
Affected products
- Mozilla Firefox: before 60.7.1; before 67.0.3 — fixed in 60.7.1, 67.0.3
- Mozilla Thunderbird: before 60.7.2 — fixed in 60.7.2
How to fix
Upgrade to a fixed version: Mozilla Firefox 60.7.1, 67.0.3; Mozilla Thunderbird 60.7.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1544386
- https://security.gentoo.org/glsa/201908-12
- https://www.mozilla.org/security/advisories/mfsa2019-18/
- https://www.mozilla.org/security/advisories/mfsa2019-20/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1544386
- https://security.gentoo.org/glsa/201908-12
- https://www.mozilla.org/security/advisories/mfsa2019-18/
- https://www.mozilla.org/security/advisories/mfsa2019-20/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2019-11707
Get alerted when CVE-2019-11707 or the next vulnerability affects your stack