What’s Vulnerable › Vulnerabilities
CVE-2019-11766
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-05 · updated 2026-06-17
- Weakness: CWE-125
Description
dhcp6.c in dhcpcd before 6.11.7 and 7.x before 7.2.2 has a buffer over-read in the D6_OPTION_PD_EXCLUDE feature.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- NetworkConfiguration dhcpcd: before 6.11.7; from 7.0.0 before 7.2.2 — fixed in 6.11.7, 7.2.2
How to fix
Upgrade to a fixed version: NetworkConfiguration dhcpcd 6.11.7, 7.2.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108172
- https://bugs.debian.org/928440
- https://roy.marples.name/archives/dhcpcd-discuss/0002428.html
- https://roy.marples.name/cgit/dhcpcd.git/commit/?h=dhcpcd-7&id=896ef4a54b0578985e5e1360b141593f1d62837b
- https://roy.marples.name/cgit/dhcpcd.git/commit/?h=dhcpcd-7&id=c1ebeaafeb324bac997984abdcee2d4e8b61a8a8
- http://www.securityfocus.com/bid/108172
- https://bugs.debian.org/928440
- https://roy.marples.name/archives/dhcpcd-discuss/0002428.html
- https://roy.marples.name/cgit/dhcpcd.git/commit/?h=dhcpcd-7&id=896ef4a54b0578985e5e1360b141593f1d62837b
- https://roy.marples.name/cgit/dhcpcd.git/commit/?h=dhcpcd-7&id=c1ebeaafeb324bac997984abdcee2d4e8b61a8a8
Get alerted when CVE-2019-11766 or the next vulnerability affects your stack