What’s Vulnerable › Vulnerabilities
CVE-2019-11807
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-05-06 · updated 2026-06-17
- Weakness: CWE-434
Description
The WooCommerce Checkout Manager plugin before 4.3 for WordPress allows media deletion via the wp-admin/admin-ajax.php?action=update_attachment_wccm wccm_default_keys_load parameter because of a nopriv_ registration and a lack of capabilities checks.
Affected products
- Visser Woocommerce Checkout Manager: before 4.3 — fixed in 4.3
How to fix
Upgrade to a fixed version: Visser Woocommerce Checkout Manager 4.3. Check the vendor advisory for mitigations.
References
- https://wpvulndb.com/vulnerabilities/9262
- https://www.wordfence.com/blog/2019/05/unauthenticated-media-deletion-vulnerability-patched-in-woocommerce-checkout-manager-plugin/
- https://wpvulndb.com/vulnerabilities/9262
- https://www.wordfence.com/blog/2019/05/unauthenticated-media-deletion-vulnerability-patched-in-woocommerce-checkout-manager-plugin/
Get alerted when CVE-2019-11807 or the next vulnerability affects your stack