What’s Vulnerable › Vulnerabilities
CVE-2019-11832
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-09 · updated 2026-06-17
- Weakness: CWE-20
Description
TYPO3 8.x before 8.7.25 and 9.x before 9.5.6 allows remote code execution because it does not properly configure the applications used for image processing, as demonstrated by ImageMagick or GraphicsMagick.
Affected products
- typo3: from 8.0.0 before 8.7.25; from 9.0.0 before 9.5.6 — fixed in 8.7.25, 9.5.6
How to fix
Upgrade to a fixed version: typo3 8.7.25, 9.5.6. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108305
- https://typo3.org/security/advisory/typo3-core-sa-2019-012/
- http://www.securityfocus.com/bid/108305
- https://typo3.org/security/advisory/typo3-core-sa-2019-012/
Get alerted when CVE-2019-11832 or the next vulnerability affects your stack