What’s Vulnerable › Vulnerabilities
CVE-2019-12044
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-22 · updated 2026-06-17
- Weakness: CWE-119
Description
A Buffer Overflow exists in Citrix NetScaler Gateway 10.5.x before 10.5.70.x, 11.1.x before 11.1.59.10, 12.0.x before 12.0.59.8, and 12.1.x before 12.1.49.23 and Citrix Application Delivery Controller 10.5.x before 10.5.70.x, 11.1.x before 11.1.59.10, 12.0.x before 12.0.59.8, and 12.1.x before 12.1.49.23.
Affected products
- Citrix Netscaler Application Delivery Controller Firmware: from 10.5.0 before 10.5.70; from 11.1.0 before 11.1.59.10; from 12.0.0 before 12.0.59.8; from 12.1.0 before 12.1.49.23 — fixed in 10.5.70, 11.1.59.10, 12.0.59.8, 12.1.49.23
- Citrix Netscaler Gateway Firmware: from 10.5.0 before 10.5.70; from 11.1.0 before 11.1.59.10; from 12.0.0 before 12.0.59.8; from 12.1.0 before 12.1.49.23 — fixed in 10.5.70, 11.1.59.10, 12.0.59.8, 12.1.49.23
How to fix
Upgrade to a fixed version: Citrix Netscaler Application Delivery Controller Firmware 10.5.70, 11.1.59.10, 12.0.59.8, 12.1.49.23; Citrix Netscaler Gateway Firmware 10.5.70, 11.1.59.10, 12.0.59.8, 12.1.49.23. Check the vendor advisory for mitigations.
References
- https://support.citrix.com/article/CTX249976
- https://support.citrix.com/v1/search?searchQuery=%22%22&lang=en&sort=cr_date_desc&prod=&pver=&ct=Security+Bulletin
- https://support.citrix.com/article/CTX249976
- https://support.citrix.com/v1/search?searchQuery=%22%22&lang=en&sort=cr_date_desc&prod=&pver=&ct=Security+Bulletin
Get alerted when CVE-2019-12044 or the next vulnerability affects your stack