What’s Vulnerable › Vulnerabilities
CVE-2019-12083
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-05-13 · updated 2026-06-17
- Weakness: CWE-125
Description
The Rust Programming Language Standard Library 1.34.x before 1.34.2 contains a stabilized method which, if overridden, can violate Rust's safety guarantees and cause memory unsafety. If the `Error::type_id` method is overridden then any type can be safely cast to any other type, causing memory safety vulnerabilities in safe code (e.g., out-of-bounds write or read). Code that does not manually implement Error::type_id is unaffected.
Affected products
- Fedoraproject Fedora: 29, 30
- openSUSE Leap: 15.1
- rust-lang rust: from 1.34.0 before 1.34.2 — fixed in 1.34.2
How to fix
Upgrade to a fixed version: rust-lang rust 1.34.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00076.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00031.html
- https://blog.rust-lang.org/2019/05/13/Security-advisory.html
- https://groups.google.com/forum/#%21topic/rustlang-security-announcements/aZabeCMUv70
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HG47HYH3AQTUMBUMX3S3G5DNAY4CBW6N/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/K6T4BNA5KQYJRIKIGGBOGBMR7TRXPHLR/
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00076.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00031.html
- https://blog.rust-lang.org/2019/05/13/Security-advisory.html
- https://groups.google.com/forum/#%21topic/rustlang-security-announcements/aZabeCMUv70
Get alerted when CVE-2019-12083 or the next vulnerability affects your stack