What’s Vulnerable › Vulnerabilities
CVE-2019-12174
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-08 · updated 2026-06-17
- Weakness: CWE-306
Description
hide.me before 2.4.4 on macOS suffers from a privilege escalation vulnerability in the connectWithExecutablePath:configFilePath:configFileName method of the me_hide_vpnhelper.Helper class in the me.hide.vpnhelper macOS privilege helper tool. This method takes user-supplied input and can be used to escalate privileges, as well as obtain the ability to run any application on the system in the root context.
Affected products
- Hide.Me: before 2.4.4 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: Hide.Me 2.4.4. Check the vendor advisory for mitigations.
References
- https://drive.google.com/open?id=1TwbjmE45gnWeYpFyH8kDU63P7u4IdPd2
- https://drive.google.com/open?id=1TwbjmE45gnWeYpFyH8kDU63P7u4IdPd2
Get alerted when CVE-2019-12174 or the next vulnerability affects your stack