What’s Vulnerable › Vulnerabilities
CVE-2019-12239
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-05-20 · updated 2026-06-17
- Weakness: CWE-89
Description
The WP Booking System plugin 1.5.1 for WordPress has no CSRF protection, which allows attackers to reach certain SQL injection issues that require administrative access.
Affected products
- murgroland WP Booking System – Booking Calendar: before 1.5.2 — fixed in 1.5.2
How to fix
Upgrade to a fixed version: murgroland WP Booking System – Booking Calendar 1.5.2. Check the vendor advisory for mitigations.
References
- http://dumpco.re/bugs/wp-plugin-wp-booking-system-sqli
- https://wordpress.org/plugins/wp-booking-system/#developers
- https://wpvulndb.com/vulnerabilities/9284
- http://dumpco.re/bugs/wp-plugin-wp-booking-system-sqli
- https://wordpress.org/plugins/wp-booking-system/#developers
- https://wpvulndb.com/vulnerabilities/9284
Get alerted when CVE-2019-12239 or the next vulnerability affects your stack