What’s Vulnerable › Vulnerabilities
CVE-2019-12309
- Severity: medium (CVSS 4.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-23 · updated 2026-06-17
- Weakness: CWE-22
Description
dotCMS before 5.1.0 has a path traversal vulnerability exploitable by an administrator to create files. The vulnerability is caused by the insecure extraction of a ZIP archive.
Affected products
- dotCMS core: before 5.1.0 — fixed in 5.1.0
How to fix
Upgrade to a fixed version: dotCMS core 5.1.0. Check the vendor advisory for mitigations.
References
- https://dotcms.com/security/SI-48
- https://github.com/dotCMS/core/compare/605e5db...364c910
- https://dotcms.com/security/SI-48
- https://github.com/dotCMS/core/compare/605e5db...364c910
Get alerted when CVE-2019-12309 or the next vulnerability affects your stack