What’s Vulnerable › Vulnerabilities
CVE-2019-12313
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-24 · updated 2026-06-17
- Weakness: CWE-79
Description
XSS exists in Shave before 2.5.3 because output encoding is mishandled during the overwrite of an HTML element.
Affected products
- Dollarshaveclub Shave: before 2.5.3 — fixed in 2.5.3
How to fix
Upgrade to a fixed version: Dollarshaveclub Shave 2.5.3. Check the vendor advisory for mitigations.
References
- https://github.com/dollarshaveclub/shave/commit/da7371b0531ba14eae48ef1bb1456a3de4cfa954#diff-074799b511e4b61923dfd3f2a3bf9b54R67
- https://github.com/dollarshaveclub/shave/compare/852b537...da7371b
- https://www.npmjs.com/advisories/822
- https://github.com/dollarshaveclub/shave/commit/da7371b0531ba14eae48ef1bb1456a3de4cfa954#diff-074799b511e4b61923dfd3f2a3bf9b54R67
- https://github.com/dollarshaveclub/shave/compare/852b537...da7371b
- https://www.npmjs.com/advisories/822
Get alerted when CVE-2019-12313 or the next vulnerability affects your stack