What’s Vulnerable › Vulnerabilities
CVE-2019-12331
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-11-07 · updated 2026-06-17
- Weakness: CWE-611
Description
PHPOffice PhpSpreadsheet before 1.8.0 has an XXE issue. The XmlScanner decodes the sheet1.xml from an .xlsx to utf-8 if something else than UTF-8 is declared in the header. This was a security measurement to prevent CVE-2018-19277 but the fix is not sufficient. By double-encoding the the xml payload to utf-7 it is possible to bypass the check for the string ‚<!ENTITY‘ and thus allowing for an xml external entity processing (XXE) attack.
Affected products
- PHPOffice PhpSpreadsheet: before 1.8.0 — fixed in 1.8.0
How to fix
Upgrade to a fixed version: PHPOffice PhpSpreadsheet 1.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/PHPOffice/PhpSpreadsheet/blob/master/CHANGELOG.md#180---2019-07-01
- https://herolab.usd.de/security-advisories/usd-2019-0046/
- https://github.com/PHPOffice/PhpSpreadsheet/blob/master/CHANGELOG.md#180---2019-07-01
- https://herolab.usd.de/security-advisories/usd-2019-0046/
Get alerted when CVE-2019-12331 or the next vulnerability affects your stack