What’s Vulnerable › Vulnerabilities
CVE-2019-12413
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-16 · updated 2026-06-17
Description
In Apache Incubator Superset before 0.31 user could query database metadata information from a database he has no access to, by using a specially crafted complex query.
Affected products
- Apache Superset: before 0.31 — fixed in 0.31
How to fix
Upgrade to a fixed version: Apache Superset 0.31. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/85ab04f8c52df8c353ecfa0ecd2ff27fc07fb8ab7566a754349806be%40%3Cdev.superset.apache.org%3E
- https://lists.apache.org/thread.html/85ab04f8c52df8c353ecfa0ecd2ff27fc07fb8ab7566a754349806be%40%3Cdev.superset.apache.org%3E
Get alerted when CVE-2019-12413 or the next vulnerability affects your stack