What’s Vulnerable › Vulnerabilities
CVE-2019-12465
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-09 · updated 2026-06-17
- Weakness: CWE-89
Description
An issue was discovered in LibreNMS 1.50.1. A SQL injection flaw was identified in the ajax_rulesuggest.php file where the term parameter is used insecurely in a database query for showing columns of a table, as demonstrated by an ajax_rulesuggest.php?debug=1&term= request.
Affected products
- librenms: before 1.53 — fixed in 1.53
How to fix
Upgrade to a fixed version: librenms 1.53. Check the vendor advisory for mitigations.
References
- https://www.darkmatter.ae/xen1thlabs/librenms-sql-injection-vulnerability-xl-19-024/
- https://www.darkmatter.ae/xen1thlabs/librenms-sql-injection-vulnerability-xl-19-024/
Get alerted when CVE-2019-12465 or the next vulnerability affects your stack