What’s Vulnerable › Vulnerabilities

CVE-2019-12471

Description

Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

Affected products

How to fix

Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.30.2, 1.31.2, 1.32.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-12471 or the next vulnerability affects your stack