What’s Vulnerable › Vulnerabilities
CVE-2019-12472
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-10 · updated 2026-06-17
Description
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Affected products
- Wikimedia Foundation MediaWiki: from 1.18.0 before 1.27.6; from 1.30.0 before 1.30.2; from 1.31.0 before 1.31.2; from 1.32.0 before 1.32.2 — fixed in 1.27.6, 1.30.2, 1.31.2, 1.32.2
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.27.6, 1.30.2, 1.31.2, 1.32.2. Check the vendor advisory for mitigations.
References
- https://lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html
- https://phabricator.wikimedia.org/T199540
- https://lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html
- https://phabricator.wikimedia.org/T199540
Get alerted when CVE-2019-12472 or the next vulnerability affects your stack