What’s Vulnerable › Vulnerabilities
CVE-2019-12528
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-04 · updated 2026-06-17
Description
An issue was discovered in Squid before 4.10. It allows a crafted FTP server to trigger disclosure of sensitive information from heap memory, such as information associated with other users' sessions or non-Squid processes.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.10
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 30, 31
- openSUSE Leap: 15.1
- Squid: before 4.10 — fixed in 4.10
How to fix
Upgrade to a fixed version: Squid 4.10. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00012.html
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00018.html
- http://www.squid-cache.org/Advisories/SQUID-2020_2.txt
- https://lists.debian.org/debian-lts-announce/2020/07/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/G6W2IQ7QV2OGREFFUBNVZIDD3RJBDE4R/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TSU6SPANL27AGK5PCGBJOKG4LUWA555J/
- https://security.gentoo.org/glsa/202003-34
- https://usn.ubuntu.com/4289-1/
- https://www.debian.org/security/2020/dsa-4682
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00012.html
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00010.html
Get alerted when CVE-2019-12528 or the next vulnerability affects your stack