What’s Vulnerable › Vulnerabilities
CVE-2019-12529
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-11 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in Squid 2.x through 2.7.STABLE9, 3.x through 3.5.28, and 4.x through 4.7. When Squid is configured to use Basic Authentication, the Proxy-Authorization header is parsed via uudecode. uudecode determines how many bytes will be decoded by iterating over the input and checking its table. The length is then used to start decoding the string. There are no checks to ensure that the length it calculates isn't greater than the input buffer. This leads to adjacent memory being decoded as well. An attacker would not be able to retrieve the decoded data unless the Squid maintainer had configured the display of usernames on error pages.
Affected products
- Canonical Ubuntu Linux: 12.04, 16.04, 18.04, 19.04
- Debian Linux: 8.0, 9.0, 10.0
- Fedoraproject Fedora: 29
- openSUSE Leap: 15.0, 15.1
- Squid: from 2.0 before 2.7; from 3.0 through 3.5.28; from 4.0 through 4.7; 2.7-stable1, 2.7-stable2, 2.7-stable3, 2.7-stable4, 2.7-stable5, 2.7-stable6 (+3) — fixed in 2.7
How to fix
Upgrade to a fixed version: Squid 2.7. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00053.html
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00056.html
- http://www.squid-cache.org/Versions/v4/changesets/
- http://www.squid-cache.org/Versions/v4/changesets/squid-4-dd46b5417809647f561d8a5e0e74c3aacd235258.patch
- https://github.com/squid-cache/squid/commits/v4
- https://lists.debian.org/debian-lts-announce/2019/07/msg00018.html
- https://lists.debian.org/debian-lts-announce/2020/07/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SPXN2CLAGN5QSQBTOV5IGVLDOQSRFNTZ/
- https://seclists.org/bugtraq/2019/Aug/42
- https://usn.ubuntu.com/4065-1/
- https://usn.ubuntu.com/4065-2/
- https://www.debian.org/security/2019/dsa-4507
Get alerted when CVE-2019-12529 or the next vulnerability affects your stack