What’s Vulnerable › Vulnerabilities
CVE-2019-12548
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-03 · updated 2026-06-17
- Weakness: CWE-434
Description
Bludit before 3.9.0 allows remote code execution for an authenticated user by uploading a php file while changing the logo through /admin/ajax/upload-logo.
Affected products
- Bludit: before 3.9.0 — fixed in 3.9.0
How to fix
Upgrade to a fixed version: Bludit 3.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/bludit/bludit/commit/d0843a4070c7d7fa596a7eb2130be15383013487
- https://github.com/bludit/bludit/compare/5e5957c...77e85e7
- https://github.com/bludit/bludit/releases/tag/3.9.0
- https://github.com/bludit/bludit/commit/d0843a4070c7d7fa596a7eb2130be15383013487
- https://github.com/bludit/bludit/compare/5e5957c...77e85e7
- https://github.com/bludit/bludit/releases/tag/3.9.0
Get alerted when CVE-2019-12548 or the next vulnerability affects your stack