What’s Vulnerable › Vulnerabilities
CVE-2019-12584
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Apcupsd 0.3.91_5, as used in pfSense through 2.4.4-RELEASE-p3 and other products, has an XSS issue in apcupsd_status.php.
Affected products
- apcupsd: 0.3.91_5
- Netgate pfSense: before 2.4.4; 2.4.4, 2.4.4-p1, 2.4.4-p2, 2.4.4-p3 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: Netgate pfSense 2.4.4. Check the vendor advisory for mitigations.
References
- https://ctrsec.io/index.php/2019/05/28/cve-2019-12584-12585-command-injection-vulnerability-on-pfsense-2-4-4-release-p3/
- https://github.com/pfsense/FreeBSD-ports/commit/b492c0ea47aba8dde2f14183e71498ba207594e3
- https://redmine.pfsense.org/issues/9556
- https://ctrsec.io/index.php/2019/05/28/cve-2019-12584-12585-command-injection-vulnerability-on-pfsense-2-4-4-release-p3/
- https://github.com/pfsense/FreeBSD-ports/commit/b492c0ea47aba8dde2f14183e71498ba207594e3
- https://redmine.pfsense.org/issues/9556
Get alerted when CVE-2019-12584 or the next vulnerability affects your stack