What’s Vulnerable › Vulnerabilities
CVE-2019-12616
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 20.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-06-05 · updated 2026-06-17
- Weakness: CWE-352
Description
An issue was discovered in phpMyAdmin before 4.9.0. A vulnerability was found that allows an attacker to trigger a CSRF attack against a phpMyAdmin user. The attacker can trick the user, for instance through a broken <img> tag pointing at the victim's phpMyAdmin database, and the attacker can potentially deliver a payload (such as a specific INSERT or DELETE statement) to the victim.
Affected products
- phpMyAdmin: before 4.9.0 — fixed in 4.9.0
How to fix
Upgrade to a fixed version: phpMyAdmin 4.9.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00017.html
- http://packetstormsecurity.com/files/153251/phpMyAdmin-4.8-Cross-Site-Request-Forgery.html
- http://www.securityfocus.com/bid/108619
- https://lists.debian.org/debian-lts-announce/2019/06/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/II4HC4QO6WUL2IRSQKCB66UBJOLLI5OV/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZKJMYVXEDXGEGRO42T6H6VOEZJ65QPQ7/
- https://www.phpmyadmin.net/security/
- https://www.phpmyadmin.net/security/PMASA-2019-4/
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00017.html
- http://packetstormsecurity.com/files/153251/phpMyAdmin-4.8-Cross-Site-Request-Forgery.html
Get alerted when CVE-2019-12616 or the next vulnerability affects your stack