What’s Vulnerable › Vulnerabilities
CVE-2019-12629: Cisco SD-WAN vManage Command Injection Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-26 · updated 2026-06-17
- Weakness: CWE-77
Description
A vulnerability in the WebUI of the Cisco SD-WAN Solution could allow an authenticated, remote attacker to inject and execute arbitrary commands with vmanage user privileges on an affected system. The vulnerability is due to insufficient input validation of data parameters for certain fields in the affected solution. An attacker could exploit this vulnerability by configuring a malicious username on the login page of the affected solution. A successful exploit could allow the attacker to inject and execute arbitrary commands with vmanage user privileges on an affected system.
Affected products
- Cisco SD-WAN vManage: before 18.3.0 — fixed in 18.3.0
How to fix
Upgrade to a fixed version: Cisco SD-WAN vManage 18.3.0. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20200122-sdwan-cmd-inject
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20200122-sdwan-cmd-inject
Get alerted when CVE-2019-12629 or the next vulnerability affects your stack