What’s Vulnerable › Vulnerabilities
CVE-2019-12630: Cisco Security Manager Java Deserialization Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 65.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-02 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the Java deserialization function used by Cisco Security Manager could allow an unauthenticated, remote attacker to execute arbitrary commands on an affected device. The vulnerability is due to insecure deserialization of user-supplied content by the affected software. An attacker could exploit this vulnerability by sending a malicious serialized Java object to a specific listener on an affected system. A successful exploit could allow the attacker to execute arbitrary commands on the device with the privileges of casuser.
Affected products
- Cisco Security Manager: before 4.18 — fixed in 4.18
How to fix
Upgrade to a fixed version: Cisco Security Manager 4.18. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-sm-java-deserial
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-sm-java-deserial
Get alerted when CVE-2019-12630 or the next vulnerability affects your stack