What’s Vulnerable › Vulnerabilities
CVE-2019-12675: Cisco Firepower Threat Defense Software Multi-instance Container Escape Vulnerabilities
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-02 · updated 2026-08-11
- Weakness: CWE-216
Description
Multiple vulnerabilities in the multi-instance feature of Cisco Firepower Threat Defense (FTD) Software could allow an authenticated, local attacker to escape the container for their FTD instance and execute commands with root privileges in the host namespace. These vulnerabilities are due to insufficient protections on the underlying filesystem. An attacker could exploit these vulnerabilities by modifying critical files on the underlying filesystem. A successful exploit could allow the attacker to execute commands with root privileges within the host namespace. This could allow the attacker to impact other running FTD instances.
Affected products
- Cisco Firepower 4110 Firmware: all versions
- Cisco Firepower 4115 Firmware: all versions
- Cisco Firepower 4120 Firmware: all versions
- Cisco Firepower 4125 Firmware: all versions
- Cisco Firepower 4140 Firmware: all versions
- Cisco Firepower 4145 Firmware: all versions
- Cisco Firepower 4150 Firmware: all versions
- Cisco Firepower 9300 Firmware: all versions
- Cisco Firepower Threat Defense Software: before 6.4.0.2 — fixed in 6.4.0.2
How to fix
Upgrade to a fixed version: Cisco Firepower Threat Defense Software 6.4.0.2. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-ftd-container-esc
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-ftd-container-esc
Get alerted when CVE-2019-12675 or the next vulnerability affects your stack