What’s Vulnerable › Vulnerabilities
CVE-2019-12676: Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software OSPF LSA Processing Denial of Service Vulnerability
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-02 · updated 2026-08-11
- Weakness: CWE-20
Description
A vulnerability in the Open Shortest Path First (OSPF) implementation of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, adjacent attacker to cause a reload of an affected device, resulting in a denial of service (DoS) condition. The vulnerability exists because the affected software improperly parses certain options in OSPF link-state advertisement (LSA) type 11 packets. An attacker could exploit this vulnerability by sending a crafted LSA type 11 OSPF packet to an affected device. A successful exploit could allow the attacker to cause a reload of the affected device, resulting in a DoS condition for client traffic that is traversing the device.
Affected products
- Cisco Adaptive Security Appliance: before 9.6.4.34 — fixed in 9.6.4.34
- Cisco ASA Software: from 9.7 before 9.8.4.8; from 9.9 before 9.9.2.59; from 9.10 before 9.10.1.27; from 9.12 before 9.12.2.1 — fixed in 9.10.1.27, 9.12.2.1, 9.8.4.8, 9.9.2.59
- Cisco Firepower Threat Defense Software: before 6.3.0.4; from 6.4.0 before 6.4.0.4 — fixed in 6.3.0.4, 6.4.0.4
How to fix
Upgrade to a fixed version: Cisco Adaptive Security Appliance 9.6.4.34; Cisco ASA Software 9.10.1.27, 9.12.2.1, 9.8.4.8, 9.9.2.59; Cisco Firepower Threat Defense Software 6.3.0.4, 6.4.0.4. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-asa-ospf-lsa-dos
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-asa-ospf-lsa-dos
Get alerted when CVE-2019-12676 or the next vulnerability affects your stack