What’s Vulnerable › Vulnerabilities
CVE-2019-12690: Cisco Firepower Management Center Command Injection Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-02 · updated 2026-06-17
- Weakness: CWE-78
Description
A vulnerability in the web UI of the Cisco Firepower Management Center (FMC) could allow an authenticated, remote attacker to inject arbitrary commands that are executed with the privileges of the root user of the underlying operating system. The vulnerability is due to insufficient validation of user-supplied input to the web UI. An attacker could exploit this vulnerability by submitting crafted input in the web UI. A successful exploit could allow an attacker to execute arbitrary commands on the device with full root privileges.
Affected products
- Cisco Firepower Management Center: before 6.3.0.5; from 6.4.0 before 6.4.0.4 — fixed in 6.3.0.5, 6.4.0.4
How to fix
Upgrade to a fixed version: Cisco Firepower Management Center 6.3.0.5, 6.4.0.4. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-fmc-com-inj
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-fmc-com-inj
Get alerted when CVE-2019-12690 or the next vulnerability affects your stack