What’s Vulnerable › Vulnerabilities
CVE-2019-12693: Cisco Adaptive Security Appliance Software Secure Copy Denial of Service Vulnerability
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-02 · updated 2026-06-17
- Weakness: CWE-704
Description
A vulnerability in the Secure Copy (SCP) feature of Cisco Adaptive Security Appliance (ASA) Software could allow an authenticated, remote attacker to cause a denial of service (DoS) condition. The vulnerability is due to the use of an incorrect data type for a length variable. An attacker could exploit this vulnerability by initiating the transfer of a large file to an affected device via SCP. To exploit this vulnerability, the attacker would need to have valid privilege level 15 credentials on the affected device. A successful exploit could allow the attacker to cause the length variable to roll over, which could cause the affected device to crash.
Affected products
- Cisco Adaptive Security Appliance: before 9.6.4.30 — fixed in 9.6.4.30
- Cisco ASA Software: from 9.7 before 9.8.4; from 9.9 before 9.9.2.50; from 9.10 before 9.10.1.22; from 9.12 before 9.12.2.1 — fixed in 9.10.1.22, 9.12.2.1, 9.8.4, 9.9.2.50
How to fix
Upgrade to a fixed version: Cisco Adaptive Security Appliance 9.6.4.30; Cisco ASA Software 9.10.1.22, 9.12.2.1, 9.8.4, 9.9.2.50. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-asa-scp-dos
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-asa-scp-dos
Get alerted when CVE-2019-12693 or the next vulnerability affects your stack