What’s Vulnerable › Vulnerabilities
CVE-2019-12694: Cisco Firepower Threat Defense Software Command Injection Vulnerability
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-02 · updated 2026-08-11
- Weakness: CWE-20
Description
A vulnerability in the command line interface (CLI) of Cisco Firepower Threat Defense (FTD) Software could allow an authenticated, local attacker with administrative privileges to execute commands on the underlying operating system with root privileges. The vulnerability is due to insufficient input validation. An attacker could exploit this vulnerability by executing a specific CLI command that includes crafted arguments. A successful exploit could allow the attacker to execute commands on the underlying OS with root privileges.
Affected products
- Cisco Firepower Threat Defense Software: before 6.3.0.5; from 6.4.0 before 6.4.0.4 — fixed in 6.3.0.5, 6.4.0.4
How to fix
Upgrade to a fixed version: Cisco Firepower Threat Defense Software 6.3.0.5, 6.4.0.4. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-ftd-cmdinj
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-ftd-cmdinj
Get alerted when CVE-2019-12694 or the next vulnerability affects your stack