What’s Vulnerable › Vulnerabilities
CVE-2019-12695: Cisco Adaptive Security Appliance and Firepower Threat Defense Software WebVPN Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-02 · updated 2026-08-11
- Weakness: CWE-79
Description
A vulnerability in the Clientless SSL VPN (WebVPN) portal of Cisco Adaptive Security Appliance (ASA) and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to conduct a cross-site scripting (XSS) attack against a user of the web-based management interface of an affected device. The vulnerability is due to insufficient validation of user-supplied input by the web-based management interface of an affected device. An attacker could exploit this vulnerability by persuading a user of the interface to click a crafted link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the interface or allow the attacker to access sensitive browser-based information.
Affected products
- Cisco Adaptive Security Appliance: before 9.6.4.31 — fixed in 9.6.4.31
- Cisco ASA Software: from 9.7 before 9.8.4.9; from 9.9 before 9.9.2.56; from 9.10 before 9.10.1.30; from 9.12 before 9.12.2.9; from 9.13 before 9.13.1 — fixed in 9.10.1.30, 9.12.2.9, 9.13.1, 9.8.4.9, 9.9.2.56
- Cisco Firepower Threat Defense Software: before 6.2.3.15; from 6.3.0 before 6.3.0.5; from 6.4.0 before 6.4.0.6 — fixed in 6.2.3.15, 6.3.0.5, 6.4.0.6
How to fix
Upgrade to a fixed version: Cisco Adaptive Security Appliance 9.6.4.31; Cisco ASA Software 9.10.1.30, 9.12.2.9, 9.13.1, 9.8.4.9; Cisco Firepower Threat Defense Software 6.2.3.15, 6.3.0.5, 6.4.0.6. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-asa-xss
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-asa-xss
Get alerted when CVE-2019-12695 or the next vulnerability affects your stack