What’s Vulnerable › Vulnerabilities
CVE-2019-12698: Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software WebVPN CPU Denial of Service Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-02 · updated 2026-08-11
- Weakness: CWE-400
Description
A vulnerability in the WebVPN feature of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to cause increased CPU utilization on an affected device. The vulnerability is due to excessive processing load for a specific WebVPN HTTP page request. An attacker could exploit this vulnerability by sending multiple WebVPN HTTP page load requests for a specific URL. A successful exploit could allow the attacker to increase CPU load on the device, resulting in a denial of service (DoS) condition, which could cause traffic to be delayed through the device.
Affected products
- Cisco Adaptive Security Appliance: before 9.6.4.31 — fixed in 9.6.4.31
- Cisco ASA Software: from 9.7 before 9.8.4.9; from 9.9 before 9.9.2.56; from 9.10 before 9.10.1.30; from 9.12 before 9.12.2.9; from 9.13 before 9.13.1 — fixed in 9.10.1.30, 9.12.2.9, 9.13.1, 9.8.4.9, 9.9.2.56
- Cisco Firepower Threat Defense Software: before 6.2.3.15; from 6.3.0 before 6.3.0.5; from 6.4.0 before 6.4.0.6 — fixed in 6.2.3.15, 6.3.0.5, 6.4.0.6
How to fix
Upgrade to a fixed version: Cisco Adaptive Security Appliance 9.6.4.31; Cisco ASA Software 9.10.1.30, 9.12.2.9, 9.13.1, 9.8.4.9; Cisco Firepower Threat Defense Software 6.2.3.15, 6.3.0.5, 6.4.0.6. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-asa-ftd-dos
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-asa-ftd-dos
Get alerted when CVE-2019-12698 or the next vulnerability affects your stack