What’s Vulnerable › Vulnerabilities
CVE-2019-12699: Cisco FXOS Software and Firepower Threat Defense Software Command Injection Vulnerabilities
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-02 · updated 2026-08-11
- Weakness: CWE-20
Description
Multiple vulnerabilities in the CLI of Cisco FXOS Software and Cisco Firepower Threat Defense (FTD) Software could allow an authenticated, local attacker to execute commands on the underlying operating system (OS) with root privileges. These vulnerabilities are due to insufficient input validation. An attacker could exploit these vulnerabilities by including crafted arguments to specific CLI commands. A successful exploit could allow the attacker to execute commands on the underlying OS with root privileges.
Affected products
- Cisco Firepower 9300 Firmware: 2.4(1.214), 2.4(1.216), 2.4(2.54), r241
- Cisco Firepower Extensible Operating System (FXOS): from 2.0 before 2.2.2.101; from 2.3 before 2.3.1.155; from 2.4 before 2.4.1.238 — fixed in 2.2.2.101, 2.3.1.155, 2.4.1.238
- Cisco Firepower Threat Defense Software: through 6.1.0; from 6.2.0 before 6.2.3.14; from 6.3.0 before 6.3.0.3 — fixed in 6.2.3.14, 6.3.0.3
How to fix
Upgrade to a fixed version: Cisco Firepower Extensible Operating System (FXOS) 2.2.2.101, 2.3.1.155, 2.4.1.238; Cisco Firepower Threat Defense Software 6.2.3.14, 6.3.0.3. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-fxos-cmd-inject
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-fxos-cmd-inject
Get alerted when CVE-2019-12699 or the next vulnerability affects your stack