What’s Vulnerable › Vulnerabilities
CVE-2019-12717: Cisco NX-OS Software Virtualization Manager Command Injection Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-25 · updated 2026-06-17
- Weakness: CWE-78
Description
A vulnerability in a CLI command related to the virtualization manager (VMAN) in Cisco NX-OS Software could allow an authenticated, local attacker to execute arbitrary commands on the underlying Linux operating system with root privileges. The vulnerability is due to insufficient validation of arguments passed to a specific VMAN CLI command on an affected device. An attacker could exploit this vulnerability by including malicious input as the argument of an affected command. A successful exploit could allow the attacker to execute arbitrary commands on the underlying Linux operating system with root privileges, which may lead to complete system compromise. An attacker would need valid administrator credentials to exploit this vulnerability.
Affected products
- Cisco NX-OS: from 6.0\(2\) before 7.0\(3\)i7\(6\); from 9.2 before 9.2\(3\); from 7.0\(3\)f before 9.2\(3\); from 7.0 before 7.3\(5\)n1\(1\); from 6.2 before 8.0\(1\) — fixed in 7.0\(3\)i7\(6\), 7.3\(5\)n1\(1\), 8.0\(1\), 9.2\(3\)
How to fix
Upgrade to a fixed version: Cisco NX-OS 7.0\(3\)i7\(6\), 7.3\(5\)n1\(1\), 8.0\(1\), 9.2\(3\). Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190925-nxos-vman-cmd-inj
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190925-nxos-vman-cmd-inj
Get alerted when CVE-2019-12717 or the next vulnerability affects your stack